re = /^(?!\.)([0-9]{3}\.[0-9]{3}\.[0-9]{3})(?!\.)/m
str = 'Affected IDs:
641.298.855 (this, lead)
213.794.868
948.895.285'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end