using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(rgb\([^)]*\)|\S+)(?:[ ]+)?)*";
string input = @"1px solid rgb(255, 255, 255) test rgb(255, 255, 255)";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}