re = /(?:(rgb\([^)]*\)|\S+)(?:[ ]+)?)*/
str = '1px solid rgb(255, 255, 255) test rgb(255, 255, 255)'
# Print the match result
str.match(re) do |match|
puts match.to_s
end