const regex = /(?:(rgb\([^)]*\)|\S+)(?:[ ]+)?)*/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(rgb\\([^)]*\\)|\\S+)(?:[ ]+)?)*', '')
const str = `1px solid rgb(255, 255, 255) test rgb(255, 255, 255)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}