package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:(rgb\([^)]*\)|\S+)(?:[ ]+)?)*`)
var str = `1px solid rgb(255, 255, 255) test rgb(255, 255, 255)`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}