#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^L([0-9a-zA-Z]+)S([0-9a-zA-Z]+)"
Local $sString = "12345" & @CRLF & _
"L12345" & @CRLF & _
"L1S1" & @CRLF & _
"LS1" & @CRLF & _
"L123S45" & @CRLF & _
"L1x23S4yZY5" & @CRLF & _
"L1x!23S4y5"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")