re = /^L([0-9a-zA-Z]+)S([0-9a-zA-Z]+)/m
str = '12345
L12345
L1S1
LS1
L123S45
L1x23S4yZY5
L1x!23S4y5'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end