using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^L([0-9a-zA-Z]+)S([0-9a-zA-Z]+)";
string input = @"12345
L12345
L1S1
LS1
L123S45
L1x23S4yZY5
L1x!23S4y5";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}