$re = '/^L([0-9a-zA-Z]+)S([0-9a-zA-Z]+)/m';
$str = '12345
L12345
L1S1
LS1
L123S45
L1x23S4yZY5
L1x!23S4y5';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);