package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^L([0-9a-zA-Z]+)S([0-9a-zA-Z]+)`)
var str = `12345
L12345
L1S1
LS1
L123S45
L1x23S4yZY5
L1x!23S4y5`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}