using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^server +\{\s+(abcdefg.+?\n\}.*?$)";
string input = @"server {
abcdefg blablablabla
pizza
#blablablabla
blablablabla {
zazazazazaza
}
turtles
#}
ninjas
blablablabla
} #comments that might or might not be here
server {
blablablabla
blablablabla
blablablabla
blablablabla
}
zabzazab
";
RegexOptions options = RegexOptions.Singleline | RegexOptions.Multiline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}