import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^server +\\{\\s+(abcdefg.+?\\n\\}.*?$)";
final String string = "server {\n"
+ " abcdefg blablablabla\n"
+ " pizza\n"
+ " #blablablabla\n"
+ " blablablabla {\n"
+ " zazazazazaza\n"
+ " }\n"
+ " turtles\n"
+ " #}\n"
+ " ninjas\n"
+ " blablablabla\n\n"
+ "} #comments that might or might not be here\n\n"
+ "server {\n"
+ " blablablabla\n"
+ " blablablabla\n"
+ " blablablabla\n"
+ " blablablabla\n"
+ "}\n\n"
+ "zabzazab\n";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}