re = /^server +\{\s+(abcdefg.+?\n\}.*?$)/m
str = 'server {
abcdefg blablablabla
pizza
#blablablabla
blablablabla {
zazazazazaza
}
turtles
#}
ninjas
blablablabla
} #comments that might or might not be here
server {
blablablabla
blablablabla
blablablabla
blablablabla
}
zabzazab
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end