const regex = /^server +\{\s+(abcdefg.+?\n\}.*?$)/sm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^server +\\{\\s+(abcdefg.+?\\n\\}.*?$)', 'sm')
const str = `server {
abcdefg blablablabla
pizza
#blablablabla
blablablabla {
zazazazazaza
}
turtles
#}
ninjas
blablablabla
} #comments that might or might not be here
server {
blablablabla
blablablabla
blablablabla
blablablabla
}
zabzazab
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}