using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"'(?:\\'|[^'])*'(*SKIP)(*F)|,";
string input = @"'this is\'nt very, funny (I dont think)','is it',12345,'nope','like with 2,4,6'";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}