re = /'(?:\\'|[^'])*'(*SKIP)(*F)|,/
str = '\'this is\\\'nt very, funny (I dont think)\',\'is it\',12345,\'nope\',\'like with 2,4,6\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end