$re = '/\'(?:\\\\\'|[^\'])*\'(*SKIP)(*F)|,/';
$str = '\'this is\\\'nt very, funny (I dont think)\',\'is it\',12345,\'nope\',\'like with 2,4,6\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);