// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"'(?:\\'|[^'])*'(*SKIP)(*F)|,").unwrap();
let string = "'this is\\'nt very, funny (I dont think)','is it',12345,'nope','like with 2,4,6'";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}