package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`'(?:\\'|[^'])*'(*SKIP)(*F)|,`)
var str = `'this is\'nt very, funny (I dont think)','is it',12345,'nope','like with 2,4,6'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}