import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<img[^>]*?itemprop=\"logo\"[^>]*?src=\"([^>\"]*)\"[^>]*>";
final String string = "<img itemprop=\"logo\" src=\"http://igid.ua/sites/default/files/imagecache/teaser-logo/images/logo/avias_33.jpg\" alt=\"ÐЗС ÐÐ²Ð¸Ð°Ñ ÐŸÐ»ÑŽÑ\" title=\"ÐЗС ÐÐ²Ð¸Ð°Ñ ÐŸÐ»ÑŽÑ\" class=\"imagecache imagecache-teaser-logo\" width=\"150\" height=\"111\">\n\n"
+ "<img itemprop=\"logo\" class=\"imagefield imagefield-field_logo\" width=\"113\" height=\"120\" title=\"Салон краÑоты Феечки\" alt=\"Салон краÑоты Феечки\" src=\"http://igid.ua/sites/default/files/images/logo/feechki_logo_2.jpg?1409836032\">";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}