import Foundation
let pattern = #"<img[^>]*?itemprop="logo"[^>]*?src="([^>"]*)"[^>]*>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<img itemprop="logo" src="http://igid.ua/sites/default/files/imagecache/teaser-logo/images/logo/avias_33.jpg" alt="ÐЗС ÐÐ²Ð¸Ð°Ñ ÐŸÐ»ÑŽÑ" title="ÐЗС ÐÐ²Ð¸Ð°Ñ ÐŸÐ»ÑŽÑ" class="imagecache imagecache-teaser-logo" width="150" height="111">
<img itemprop="logo" class="imagefield imagefield-field_logo" width="113" height="120" title="Салон краÑоты Феечки" alt="Салон краÑоты Феечки" src="http://igid.ua/sites/default/files/images/logo/feechki_logo_2.jpg?1409836032">
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)