import re
regex = re.compile(r"<img[^>]*?itemprop=\"logo\"[^>]*?src=\"([^>\"]*)\"[^>]*>")
test_str = ("<img itemprop=\"logo\" src=\"http://igid.ua/sites/default/files/imagecache/teaser-logo/images/logo/avias_33.jpg\" alt=\"ÐЗС ÐÐ²Ð¸Ð°Ñ ÐŸÐ»ÑŽÑ\" title=\"ÐЗС ÐÐ²Ð¸Ð°Ñ ÐŸÐ»ÑŽÑ\" class=\"imagecache imagecache-teaser-logo\" width=\"150\" height=\"111\">\n\n"
"<img itemprop=\"logo\" class=\"imagefield imagefield-field_logo\" width=\"113\" height=\"120\" title=\"Салон краÑоты Феечки\" alt=\"Салон краÑоты Феечки\" src=\"http://igid.ua/sites/default/files/images/logo/feechki_logo_2.jpg?1409836032\">")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")