re = /<img[^>]*?itemprop="logo"[^>]*?src="([^>"]*)"[^>]*>/
str = '<img itemprop="logo" src="http://igid.ua/sites/default/files/imagecache/teaser-logo/images/logo/avias_33.jpg" alt="ÐЗС ÐÐ²Ð¸Ð°Ñ ÐŸÐ»ÑŽÑ" title="ÐЗС ÐÐ²Ð¸Ð°Ñ ÐŸÐ»ÑŽÑ" class="imagecache imagecache-teaser-logo" width="150" height="111">
<img itemprop="logo" class="imagefield imagefield-field_logo" width="113" height="120" title="Салон краÑоты Феечки" alt="Салон краÑоты Феечки" src="http://igid.ua/sites/default/files/images/logo/feechki_logo_2.jpg?1409836032">'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end