# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?(DEFINE) # Definitions
(?<skip>\#others.*?\#others) # What we should skip
)
(?&skip)(*SKIP)(*FAIL) # Skip it
|
(?<needle>batman\s+(\d+)\s+batman) # Match it/batman new-$3 batman/gsx;t' <<< "#capture
batman 12345 batman
batman 234 batman
batman 35655 batman
batman 1311 batman
#capture
#others
batman 12345 batman
batman 234 batman
batman 35655 batman
batman 1311 batman
#others"