$re = '/(?(DEFINE) # Definitions
(?<skip>\#others.*?\#others) # What we should skip
)
(?&skip)(*SKIP)(*FAIL) # Skip it
|
(?<needle>batman\s+(\d+)\s+batman) # Match it/sx';
$str = '#capture
batman 12345 batman
batman 234 batman
batman 35655 batman
batman 1311 batman
#capture
#others
batman 12345 batman
batman 234 batman
batman 35655 batman
batman 1311 batman
#others';
$subst = "batman new-$3 batman";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;