#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?sx)(?(DEFINE) # Definitions" & @CRLF & _
" (?<skip>\#others.*?\#others) # What we should skip" & @CRLF & _
")" & @CRLF & _
"(?&skip)(*SKIP)(*FAIL) # Skip it" & @CRLF & _
"|" & @CRLF & _
"(?<needle>batman\s+(\d+)\s+batman) # Match it"
Local $sString = "#capture" & @CRLF & _
"batman 12345 batman" & @CRLF & _
"batman 234 batman" & @CRLF & _
"batman 35655 batman" & @CRLF & _
"batman 1311 batman" & @CRLF & _
"#capture" & @CRLF & _
"" & @CRLF & _
"#others" & @CRLF & _
"batman 12345 batman" & @CRLF & _
"batman 234 batman" & @CRLF & _
"batman 35655 batman" & @CRLF & _
"batman 1311 batman" & @CRLF & _
"#others"
Local $sSubst = "batman new-$3 batman"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)