// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?sx)(?(DEFINE) # Definitions
(?<skip>\#others.*?\#others) # What we should skip
)
(?&skip)(*SKIP)(*FAIL) # Skip it
|
(?<needle>batman\s+(\d+)\s+batman) # Match it").unwrap();
let string = "#capture
batman 12345 batman
batman 234 batman
batman 35655 batman
batman 1311 batman
#capture
#others
batman 12345 batman
batman 234 batman
batman 35655 batman
batman 1311 batman
#others";
let substitution = "batman new-$3 batman";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}