import Foundation
let pattern = ##"""
(?(DEFINE) # Definitions
(?<skip>\#others.*?\#others) # What we should skip
)
(?&skip)(*SKIP)(*FAIL) # Skip it
|
(?<needle>batman\s+(\d+)\s+batman) # Match it
"""##
let regex = try! NSRegularExpression(pattern: pattern, options: [.allowCommentsAndWhitespace, .dotMatchesLineSeparators])
let testString = ##"""
#capture
batman 12345 batman
batman 234 batman
batman 35655 batman
batman 1311 batman
#capture
#others
batman 12345 batman
batman 234 batman
batman 35655 batman
batman 1311 batman
#others
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"batman new-$3 batman"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)