import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(self|parent|selfOrParent)|(?:(prevSibling|ancestor|selfOrAncestor)((?:#[\\w-]+)?(?:\\.[\\w-]+)*)))\\[(?:(id|ref)|(?:data)-([\\w-]+))\\]";
final String string = "self[id]\n"
+ "self[data-key]\n"
+ "self[ref]\n"
+ "parent[id]\n"
+ "parent[data-key]\n"
+ "parent[ref]\n"
+ "selfOrParent[id]\n"
+ "selfOrParent[data-key]\n"
+ "selfOrParent[ref]\n\n"
+ "prevSibling[id]\n"
+ "prevSibling[data-key]\n"
+ "prevSibling[ref]\n"
+ "prevSibling#id[id]\n"
+ "prevSibling#id[data-key]\n"
+ "prevSibling#id[ref]\n\n"
+ "ancestor[id]\n"
+ "ancestor#anId[id]\n"
+ "ancestor#anId.class[id]\n"
+ "ancestor#anId.class.class[id]\n"
+ "ancestor.class[id]\n"
+ "ancestor.class.class[id]\n\n"
+ "ancestor[data-key]\n"
+ "ancestor#anId[data-key]\n"
+ "ancestor#anId.class[data-key]\n"
+ "ancestor#anId.class.class[data-key]\n"
+ "ancestor.class[data-key]\n"
+ "ancestor.class.class[data-key]\n\n"
+ "ancestor[ref]\n"
+ "ancestor#anId[ref]\n"
+ "ancestor#anId.class[ref]\n"
+ "ancestor#anId.class.class[ref]\n"
+ "ancestor.class[ref]\n"
+ "ancestor.class.class[ref]\n\n"
+ "selfOrAncestor[id]\n"
+ "selfOrAncestor#anId[id]\n"
+ "selfOrAncestor#anId.class[id]\n"
+ "selfOrAncestor#anId.class.class[id]\n"
+ "selfOrAncestor.class[id]\n"
+ "selfOrAncestor.class.class[id]\n\n"
+ "selfOrAncestor[data-key]\n"
+ "selfOrAncestor#anId[data-key]\n"
+ "selfOrAncestor#anId.class[data-key]\n"
+ "selfOrAncestor#anId.class.class[data-key]\n"
+ "selfOrAncestor.class[data-key]\n"
+ "selfOrAncestor.class.class[data-key]\n\n"
+ "selfOrAncestor[ref]\n"
+ "selfOrAncestor#anId[ref]\n"
+ "selfOrAncestor#anId.class[ref]\n"
+ "selfOrAncestor#anId.class.class[ref]\n"
+ "selfOrAncestor.class[ref]\n"
+ "selfOrAncestor.class.class[ref]\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}