# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:(self|parent|selfOrParent)|(?:(prevSibling|ancestor|selfOrAncestor)((?:#[\w-]+)?(?:\.[\w-]+)*)))\[(?:(id|ref)|(?:data)-([\w-]+))\]"
test_str = ("self[id]\n"
"self[data-key]\n"
"self[ref]\n"
"parent[id]\n"
"parent[data-key]\n"
"parent[ref]\n"
"selfOrParent[id]\n"
"selfOrParent[data-key]\n"
"selfOrParent[ref]\n\n"
"prevSibling[id]\n"
"prevSibling[data-key]\n"
"prevSibling[ref]\n"
"prevSibling#id[id]\n"
"prevSibling#id[data-key]\n"
"prevSibling#id[ref]\n\n"
"ancestor[id]\n"
"ancestor#anId[id]\n"
"ancestor#anId.class[id]\n"
"ancestor#anId.class.class[id]\n"
"ancestor.class[id]\n"
"ancestor.class.class[id]\n\n"
"ancestor[data-key]\n"
"ancestor#anId[data-key]\n"
"ancestor#anId.class[data-key]\n"
"ancestor#anId.class.class[data-key]\n"
"ancestor.class[data-key]\n"
"ancestor.class.class[data-key]\n\n"
"ancestor[ref]\n"
"ancestor#anId[ref]\n"
"ancestor#anId.class[ref]\n"
"ancestor#anId.class.class[ref]\n"
"ancestor.class[ref]\n"
"ancestor.class.class[ref]\n\n"
"selfOrAncestor[id]\n"
"selfOrAncestor#anId[id]\n"
"selfOrAncestor#anId.class[id]\n"
"selfOrAncestor#anId.class.class[id]\n"
"selfOrAncestor.class[id]\n"
"selfOrAncestor.class.class[id]\n\n"
"selfOrAncestor[data-key]\n"
"selfOrAncestor#anId[data-key]\n"
"selfOrAncestor#anId.class[data-key]\n"
"selfOrAncestor#anId.class.class[data-key]\n"
"selfOrAncestor.class[data-key]\n"
"selfOrAncestor.class.class[data-key]\n\n"
"selfOrAncestor[ref]\n"
"selfOrAncestor#anId[ref]\n"
"selfOrAncestor#anId.class[ref]\n"
"selfOrAncestor#anId.class.class[ref]\n"
"selfOrAncestor.class[ref]\n"
"selfOrAncestor.class.class[ref]\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.