use strict;
my $str = 'self[id]
self[data-key]
self[ref]
parent[id]
parent[data-key]
parent[ref]
selfOrParent[id]
selfOrParent[data-key]
selfOrParent[ref]
prevSibling[id]
prevSibling[data-key]
prevSibling[ref]
prevSibling#id[id]
prevSibling#id[data-key]
prevSibling#id[ref]
ancestor[id]
ancestor#anId[id]
ancestor#anId.class[id]
ancestor#anId.class.class[id]
ancestor.class[id]
ancestor.class.class[id]
ancestor[data-key]
ancestor#anId[data-key]
ancestor#anId.class[data-key]
ancestor#anId.class.class[data-key]
ancestor.class[data-key]
ancestor.class.class[data-key]
ancestor[ref]
ancestor#anId[ref]
ancestor#anId.class[ref]
ancestor#anId.class.class[ref]
ancestor.class[ref]
ancestor.class.class[ref]
selfOrAncestor[id]
selfOrAncestor#anId[id]
selfOrAncestor#anId.class[id]
selfOrAncestor#anId.class.class[id]
selfOrAncestor.class[id]
selfOrAncestor.class.class[id]
selfOrAncestor[data-key]
selfOrAncestor#anId[data-key]
selfOrAncestor#anId.class[data-key]
selfOrAncestor#anId.class.class[data-key]
selfOrAncestor.class[data-key]
selfOrAncestor.class.class[data-key]
selfOrAncestor[ref]
selfOrAncestor#anId[ref]
selfOrAncestor#anId.class[ref]
selfOrAncestor#anId.class.class[ref]
selfOrAncestor.class[ref]
selfOrAncestor.class.class[ref]
';
my $regex = qr/(?:(self|parent|selfOrParent)|(?:(prevSibling|ancestor|selfOrAncestor)((?:#[\w-]+)?(?:\.[\w-]+)*)))\[(?:(id|ref)|(?:data)-([\w-]+))\]/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}