re = /(?:(self|parent|selfOrParent)|(?:(prevSibling|ancestor|selfOrAncestor)((?:#[\w-]+)?(?:\.[\w-]+)*)))\[(?:(id|ref)|(?:data)-([\w-]+))\]/m
str = 'self[id]
self[data-key]
self[ref]
parent[id]
parent[data-key]
parent[ref]
selfOrParent[id]
selfOrParent[data-key]
selfOrParent[ref]
prevSibling[id]
prevSibling[data-key]
prevSibling[ref]
prevSibling#id[id]
prevSibling#id[data-key]
prevSibling#id[ref]
ancestor[id]
ancestor#anId[id]
ancestor#anId.class[id]
ancestor#anId.class.class[id]
ancestor.class[id]
ancestor.class.class[id]
ancestor[data-key]
ancestor#anId[data-key]
ancestor#anId.class[data-key]
ancestor#anId.class.class[data-key]
ancestor.class[data-key]
ancestor.class.class[data-key]
ancestor[ref]
ancestor#anId[ref]
ancestor#anId.class[ref]
ancestor#anId.class.class[ref]
ancestor.class[ref]
ancestor.class.class[ref]
selfOrAncestor[id]
selfOrAncestor#anId[id]
selfOrAncestor#anId.class[id]
selfOrAncestor#anId.class.class[id]
selfOrAncestor.class[id]
selfOrAncestor.class.class[id]
selfOrAncestor[data-key]
selfOrAncestor#anId[data-key]
selfOrAncestor#anId.class[data-key]
selfOrAncestor#anId.class.class[data-key]
selfOrAncestor.class[data-key]
selfOrAncestor.class.class[data-key]
selfOrAncestor[ref]
selfOrAncestor#anId[ref]
selfOrAncestor#anId.class[ref]
selfOrAncestor#anId.class.class[ref]
selfOrAncestor.class[ref]
selfOrAncestor.class.class[ref]
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end