package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ismU)<a([^>]*?)href=["|'](https?):\/\/((?:[^\.]{3,}\.)?google\.ru\/?)["|']([^>]*?)>([^<]*?)<\/a>`)
var str = `<a href="https://www1.google.ru"></a>
<a href="http://google.ru"></a>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}