import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a([^>]*?)href=[\"|'](https?):\\/\\/((?:[^\\.]{3,}\\.)?google\\.ru\\/?)[\"|']([^>]*?)>([^<]*?)<\\/a>";
final String string = "<a href=\"https://www1.google.ru\"></a>\n"
+ "<a href=\"http://google.ru\"></a>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.DOTALL | Pattern.MULTILINE | Pattern.UNICODE_CHARACTER_CLASS);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}