re = /<a([^>]*?)href=["|'](https?):\/\/((?:[^\.]{3,}\.)?google\.ru\/?)["|']([^>]*?)>([^<]*?)<\/a>/im
str = '<a href="https://www1.google.ru"></a>
<a href="http://google.ru"></a>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end