const regex = /<a([^>]*?)href=["|'](https?):\/\/((?:[^\.]{3,}\.)?google\.ru\/?)["|']([^>]*?)>([^<]*?)<\/a>/ism;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<a([^>]*?)href=["|\'](https?):\\\/\\\/((?:[^\\.]{3,}\\.)?google\\.ru\\\/?)["|\']([^>]*?)>([^<]*?)<\\\/a>', 'ism')
const str = `<a href="https://www1.google.ru"></a>
<a href="http://google.ru"></a>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}