$re = '/<a([^>]*?)href=["|\'](https?):\/\/((?:[^\.]{3,}\.)?google\.ru\/?)["|\']([^>]*?)>([^<]*?)<\/a>/ismU';
$str = '<a href="https://www1.google.ru"></a>
<a href="http://google.ru"></a>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);