# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!\\)\|/\n/gim;t' <<< "fielda|field b |field\|with\|pipe\|inside"