$re = '/(?<!\\\\)\|/im';
$str = 'fielda|field b |field\\|with\\|pipe\\|inside';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;