const regex = /(?<!\\)\|/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\\\)\\|', 'gim')
const str = `fielda|field b |field\\|with\\|pipe\\|inside`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);