import re
regex = re.compile(r"(?<!\\)\|", flags=re.IGNORECASE | re.MULTILINE)
test_str = "fielda|field b |field\\|with\\|pipe\\|inside"
subst = "\\n"
result = regex.sub(subst, test_str)
if result:
print(result)