#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)EST VA CLD:\s*([\s\S]+?)\n(?=[^:\n]*:)"
Local $sString = "OBS VA DTG: 07/1200Z" & @CRLF & _
"EST VA CLD: SFC/FL200 S2115 W17500 - S2015 W17000 - S2415" & @CRLF & _
" W16930 - S2300 W17815 - S2030 W17615 - S2030" & @CRLF & _
" W17515 - S2115 W17500 FL200/600 NO VA EXP" & @CRLF & _
"FCST VA CLD+6 HR: 07/1800Z SFC/FL600 NO VA EXP" & @CRLF & _
"FCST VA CLD+12 HR: 08/0000Z SFC/FL600 NO VA EXP" & @CRLF & _
"FCST VA CLD+18 HR: 08/0600Z SFC/FL600 NO VA EXP"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")