import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "EST VA CLD:\\s*([\\s\\S]+?)\\n(?=[^:\\n]*:)";
final String string = "OBS VA DTG: 07/1200Z\n"
+ "EST VA CLD: SFC/FL200 S2115 W17500 - S2015 W17000 - S2415\n"
+ " W16930 - S2300 W17815 - S2030 W17615 - S2030\n"
+ " W17515 - S2115 W17500 FL200/600 NO VA EXP\n"
+ "FCST VA CLD+6 HR: 07/1800Z SFC/FL600 NO VA EXP\n"
+ "FCST VA CLD+12 HR: 08/0000Z SFC/FL600 NO VA EXP\n"
+ "FCST VA CLD+18 HR: 08/0600Z SFC/FL600 NO VA EXP";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}