# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"EST VA CLD:\s*([\s\S]+?)\n(?=[^:\n]*:)"
test_str = ("OBS VA DTG: 07/1200Z\n"
"EST VA CLD: SFC/FL200 S2115 W17500 - S2015 W17000 - S2415\n"
" W16930 - S2300 W17815 - S2030 W17615 - S2030\n"
" W17515 - S2115 W17500 FL200/600 NO VA EXP\n"
"FCST VA CLD+6 HR: 07/1800Z SFC/FL600 NO VA EXP\n"
"FCST VA CLD+12 HR: 08/0000Z SFC/FL600 NO VA EXP\n"
"FCST VA CLD+18 HR: 08/0600Z SFC/FL600 NO VA EXP")
matches = re.finditer(regex, test_str, re.IGNORECASE | re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.