import Foundation
let pattern = #"EST VA CLD:\s*([\s\S]+?)\n(?=[^:\n]*:)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
OBS VA DTG: 07/1200Z
EST VA CLD: SFC/FL200 S2115 W17500 - S2015 W17000 - S2415
W16930 - S2300 W17815 - S2030 W17615 - S2030
W17515 - S2115 W17500 FL200/600 NO VA EXP
FCST VA CLD+6 HR: 07/1800Z SFC/FL600 NO VA EXP
FCST VA CLD+12 HR: 08/0000Z SFC/FL600 NO VA EXP
FCST VA CLD+18 HR: 08/0600Z SFC/FL600 NO VA EXP
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)