#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "radio (?P<radio>[\d.-]+)"
Local $sString = "P 0.0 2 576233 5322262 349781 167393 0 39965 216687 1740539 132012 66156 0 13006 (radio 8.-652% / 10.12% tx 5.93% / 6.74% listen 2.83% / 3.38%)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")