re = /radio (?P<radio>[\d.-]+)/
str = 'P 0.0 2 576233 5322262 349781 167393 0 39965 216687 1740539 132012 66156 0 13006 (radio 8.-652% / 10.12% tx 5.93% / 6.74% listen 2.83% / 3.38%)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end