// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"radio (?P<radio>[\d.-]+)").unwrap();
let string = "P 0.0 2 576233 5322262 349781 167393 0 39965 216687 1740539 132012 66156 0 13006 (radio 8.-652% / 10.12% tx 5.93% / 6.74% listen 2.83% / 3.38%)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}