package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`radio (?P<radio>[\d.-]+)`)
var str = `P 0.0 2 576233 5322262 349781 167393 0 39965 216687 1740539 132012 66156 0 13006 (radio 8.-652% / 10.12% tx 5.93% / 6.74% listen 2.83% / 3.38%)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}