const regex = /radio (?P<radio>[\d.-]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('radio (?P<radio>[\\d.-]+)', 'g')
const str = `P 0.0 2 576233 5322262 349781 167393 0 39965 216687 1740539 132012 66156 0 13006 (radio 8.-652% / 10.12% tx 5.93% / 6.74% listen 2.83% / 3.38%)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}